.netCURRENCY Exchange

Navigation: »No topics above this level«

.netCURRENCY Exchange

 Return to chapter overview

Please feel free to navigate this help document for information on installation, developer documentation, reference, samples, support and licensing.


Overview

Overview of .netCURRENCY

Navigation: .netCURRENCY Exchange >

Overview of .netCURRENCY

 Return to chapter overview

.netCURRENCY provides real-time currency exchange to and from every major currency in the world.

.netCURRENCY is ideal for global ecommerce applications allowing you to easily offer customers the ability to browse rates in their own local currency. It can also be used in portal applications as a value added service for site visitors.

Product Features:

· Real-time rate acquisition can be configured to occur automatically at set intervals. For example run once per day or even run on demand.
· In between real-time rate retrieval requests are responded to immediately from an XML cache containing all rating data.
· When new rating information is provided, the cache system is automatically updated. This ensures maximum performance with minimal network overhead.
· Multi-level cache implementation greatly reduced network and file IO by storing data in memory with persistent file backup.
· Convert to and from over 190 currencies and precious metals.
· Return the current rate for any given currency relative to a selected base currency.
· Control the number of decimal places in your return value after conversion.
· Generate a combo box with all available currency options with 1 line of script. Sort by name, currency code etc.
· Adjust the returned rates plus or minus a percentage or fixed rate automatically.
· Return the last update time, date and success status.
· Ability to modify stored rates directly and have the changes immediately be cached for future requests.
· Handles conversions to and from currencies that were replaced with the Euro [NEW]
· Supports formatting currency returns based on a specified currency, this accurately formats a string including decimal, delimintation, symbol, placement and more. [NEW]
· Stand alone format function for formatting your own values [NEW]
· Supports image overrides to use images in place of text currency symbols [NEW]
· Per currency culture definitions used by the formatting functions. [NEW]

Learn more about .netCURRENCY and play with a live demo at our web site.


What's New

Navigation: .netCURRENCY Exchange >

What's New

 Return to chapter overview

.netCURRENCY was originally released in 2001 and has continued to be enhanced based on client suggestions. We are pleased to announce the 3.0 release in July 2016 which includes the following:

· Updated automated currency handling for 30+ currencies
· New paid and free plan options through 3rd party provider: currencylayer.com for 167+ currencies

Prior released included

· Special Euro handling, currencies that have moved to the euro will be accurately rated based on their fixed rate versus the Euro and the correct currency symbol / code returned.

· Complete currency formatting based on local: an all new method, convertformat, will perform a currency conversion the same as convert however it will return a string formatted as the target currency including symbol, spacing, seperator, places, and orientation specific to that currency.

· The format functionality is also exposed on its own through the new format method which allows for any raw number or return to be formatted as a string of that currency type.

· Currency symbol image support and override. You can now define images for currency symbols and they will be placed appropriately based on that currencies symbol rules. To specify an image set the symbol to an image name in the currency XML file and it will be automatically detected and displayed.

· Culture definitions: Each currency can now be defined with a culture definition which is used for formatting currency values by the new format and convertformat methods


Installation

Navigation: »No topics above this level«

Installation

 Return to chapter overview

System Requirements provides information on the minimum requirements for running .netCURRENCY.

Instructions provides information on how to install .netCURRENCY


System Requirements

Navigation: Installation >

System Requirements

 Return to chapter overview

.netCURRENCY is designed to be used in a web server environment.

Supported Operating System:

· Windows 2000 Server
· Windows XP Professional
· Windows 2000 Professional
· Windows .NET Server

Additional Requirements:

· ASP.NET
· .NET Framework

Downloads and Links:

· If you are running a supported Operating system but are not yet running ASP.NET you can download it for free from Microsoft through www.asp.net.


Instructions

Navigation: Installation >

Instructions

 Return to chapter overview

.netCURRENCY can be deployed quickly and easily without any special installation or registration requirements. It will work with a dedicated server, shared server, hosted server etc. so long as the server supports ASP.NET - as soon as you copy your files to your web server you can start using .netCURRENCY!

Procedure:

· Unzip distribution
· Copy / FTP web files to a directory of your choice within your web servers root directory
· Ensure that dotnetcurrency.dll and your purchase key are located in the /bin directory and that the /bin directory is in the root (top level) of your web site or, if not, that you have created an application for the subdirectory which contains your /bin directory.
· You may now use the .netCURRENCY samples through http://localhost for development or the domain you are licensed for in production.

Using a Virtual Directory:

· Unzip distribution
· Place files in any directory you wish
· Using the IIS administration (MMC), create a virtual directory under your web site pointing to the /web directory that contains the .netCURRENCYsamples. Click here for more information on virtual directory creation.
· Ensure that your purchase key is located in the /bin directory along with dotnetcurrency.dll
· You may now use the .netCURRENCY samples through http://localhost for development or the domain you are licensed for in production.


Developer Documentation

Navigation: »No topics above this level«

Developer Documentation

 Return to chapter overview

This topic includes a complete reference of the methods and properties included with .netCURRENCY as well as some examples.


Reference

Navigation: Developer Documentation >

Reference

 Return to chapter overview

Detailed guide to .netCURRENCY methods and properties.


Methods

Navigation: Developer Documentation > Reference >

Methods

 Return to chapter overview

Convert: Converts the amount provided to the currency specified or uses the base currency if it is not specified. The first parameter is the amount to be converted, the second is the code to be converted to, the third is the number of decimals to return and the 4th the base currency. This method returns a raw value that can be used in further processing.

obj.Convert(100,"CAD","2","USD")

obj.Convert(100,"CAD")

ConvertFormat: Converts the amount provided to the currency specified or uses the base currency if it is not specified. The first parameter is the amount to be converted, the second is the code to be converted to, the third is the base currency which is optional. This method returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol.

obj.ConvertFormat(100,"CAD","USD")

obj.ConvertFormat(100,"CAD")

Format: Returns a formatted string as the currency should be formatted including decimals, seperator, and currency symbol. The first parameter accepts the amount, the second a currency code. If currency code is not specified, the base currency will be used.

obj.Format(100,"CAD")

CodeToCurrency: Returns the applicable full currency name from the provided currency code.

obj.CodeToCurrency("CAD")

CurrencyToCode: Returns the applicable currency code from the provided full currency name.

obj.CurrencyToCode("Canadian Dollar")

Rate: Returns the current exchange rate for the specified currency code for the base currency in use. Optionally you can specify both a code and base to get a relative rate.

obj.Rate("CDN")

obj.Rate("CDN","USD")

Update: Takes a single parameter of string update period and performs an update as required. Examples: "12,H" update if the lastupdate is more than 12 hours. "1,D" update if the lastupdate is more than 1 day.

obj.Update("1,D")

an overload is supported to optionally work with the 3rd party provider using your account from currencylayer.com

obj.Update("1,D","accesskeystring")

CurrencyList: Returns a combobox for use in HTML for selecting a currency. The combox supports a number of formats and sort orders controlled with a true/false value. If this is ommited currencies are displayed by "Currency Name", if this is set to true they are displayed by "code (currency name)", and if set to false they are displayed with "currency name (code)". There are also 2 string parameters that control the combobox name and default currency value selected. This method may also be called without parameters in which it will take default settings.

field name of FieldName, default currency selected of USD and display with code (currency):

obj.CurrencyList("FieldName","USD",true)

default for fieldname and currency, display as currency name (code):

obj.CurrencyList(false)


Properties

Navigation: Developer Documentation > Reference >

Properties

 Return to chapter overview

Base: Sets the base currency. This determines which currency is selected by default in the list method and also which currency values are fetched by the update method and stored in the xml cache. Since .netCURRENCY converts rates to and from any currency you do not need to change the base currency in order to convert from a different currency than your base setting.

obj.base = "USD"

Xml: Sets the path and file name for the XML files used to cache the currency rates. This property defaults to currencies.xml in the same directory as the calling script and is therefore optional. This property determines where the update method will create the file from the real-time update as well as specifing the source file to be used when doing a conversion.

obj.xml = "/mycurrencyfile.xml"

Error: The error property is populated if .netCURRENCY encounters an error when processing. Read only.

obj.error

LastUpdate: Returns the date and time of the last real-time update. Read only.

obj.LastUpdate

UpdateStatus: Returns true or false, this property will indicate if the last update was sucessful or not. Read only.

obj.UpdateStatus

AdjustRate: Controls if the returned currency calculation will be adjusted plus or minus a fixed amount or percentage. For example if you wish to display conversions between common currencies however the rates are consistently higher than your banks rates you may wish to set the adjust property.

obj.AdjustRate = "12%"

obj.AdjustRate = "1.52"

obj.AdjustRate = "-20"

Timeout: Sets the timeout in seconds that .netCURRENCY will wait for the update method to return. Default is 45 seconds.

obj.TimeOut = 30

Version: Returns the version of .netCURRENCY in use.


Web Control

Navigation: Developer Documentation > Reference >

Web Control

 Return to chapter overview

CurrencyList: A web server control that provides a list of country / currency values. This is the web control equivilant of the list method. The DisplayFormat property accepts the following options: currencycode, codecurrency, currency, or code. This property affects the display value in the dropdown that is rendered. The selected currency property determines which currency is selected by default. This control can be called multiple times on a single page, a common case being rendering two selections for conversion between currencies.

Example usage:

<dotnet:CurrencyList id="BaseCurrency" DisplayFormat="currencycode" SelectedCurrency="USD" runat="server"/>


Examples

Navigation: Developer Documentation >

Examples

 Return to chapter overview

Examples can be found in the /web directory in both C# (/csharp) and VB.NET (/vbnet). The following files are included:

ConvertForm.aspx: A forms based demo that demonstrates converting between two user selected currencies with an amount they specify.

FullDemo.aspx: A demo which demonstrates the various methods and properties of .netCURRENCY including converting codes to currency and vise versa, updates, rating and more.

Currencies.xml: The XML file where currency data is stored.


Support

Navigation: »No topics above this level«

Support

 Return to chapter overview

Before contacting support be sure to read the frequent questions listings and review the support policy.


Frequent Questions

Navigation: Support >

Frequent Questions

 Return to chapter overview

Can .netCURRENCY be used from traditional ASP scripts?

No, .netCURRENCY requires ASP.NET, please see system requirements for more details.

How often are rates updated and where are they from?

Rates are updated daily from Oanda.

Why do some currencies display with currency symbols that do not display correctly?

.netCURRENCY's formatting functionality will return a currency formatted using the appropriate symbol. For some obscure countries your local system may not have that symbol / language installed so it won't appear. Someone from that country would be able to view the symbol correctly. If this is a common country or you feel many people from outside the country will select it you can override the symbol yourself with any text or image.


Support Policy

Navigation: Support >

Support Policy

 Return to chapter overview

30 days of priority email support is provided with purchase. After this point free support is still provided on an as available basis.

Support is offered for evaluations / presales on an as available basis.

Priority support contracts can be purchased.


Contacting Support

Navigation: Support >

Contacting Support

 Return to chapter overview

You can contact support by emailing info@dotnetcurrency.com

Please be sure to include the following information:

· Your orderid provided when you purchased .netCURRENCY
· A detailed description of your problem
· An exact error message if applicable
· Specifics of your server environment


Licensing Information

Navigation: »No topics above this level«

Licensing Information

 Return to chapter overview

This chapter includes information on pricing as well as the license agreement.


Pricing & Purchase

Navigation: Licensing Information >

Pricing & Purchase

 Return to chapter overview

.netCURRENCY is Licensed per site / store:

Single Site $125: Usage for a single site / store.

Bonus: We are including a free development license with each license of .netCURRENCY sold.

When you purchase .netCURRENCY you are asked to provide your web site address. Your license is bound to this address and allows for the product to work on this site only, for a single store. With each purchase, a free development license is included which allows you to use the product locally for development purposes at no additional charge.


License Agreement

Navigation: Licensing Information >

License Agreement

 Return to chapter overview

This license agreement is a legal agreement between you and Corporate Web Solutions for .netCURRENCY. By using this product/key you agree to be bound by the terms of this agreement.

This software/key is protected by national and international copyright laws. This software/key is licensed, not sold.

Granted Rights: This license grants you the right to install this software/key for use on a single (1) web site / store for the domain specified when your key was purchased. In addition, you may use the product for local development purposes on a single (1) computer system. This product/key is licensed per store (also known as per domain or per site).

Limitations: You may not reverse engineer, decompile, or disassemble .netCURRENCY. You may not rent or lease this software/key, you may not transfer your rights under this license agreement. A license may not be used for any domain other than that specified at the time of purchase, licenses can not be transfered to different domains. .netCURRENCY is designed to be used in web sites for currency conversion. .netCURRENCY depends on a third party web sites for rating information and provides no guarantee, expressed or implied, as to the accuracy of the data or its continued return. .netCURRENCY is not a development tool and may not be used in any other application outside of a web server environment. .netCURRENCY may not be integrated with or incorporated into any software product or script sold or offered to any 3rd party. A single .netCURRENCY license may not be used in an ISP / Mall environment, each site / store must have its own unique license.

Ownership: Corporate Web Solutions retains ownership of the software/key.

Liability: In no event shall Corporate Web Solutions be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of information or any other pecuniary loss) arising out of the use of inability to use this software/key, even if Corporate Web Solutions has been advised of the possibility of such damages.

Termination: Without prejudice to any other rights, Corporate Web Solutions may terminate this license agreement if you fail to comply with the terms and conditions of this agreement. In such event, you must destroy all copies of .netCURRENCY, any derivative work, and all of its component parts.

General: By installing this software/key you acknowledge that you have read this license agreement, understand it, and agree to be bound by its terms and conditions.


Using the built-in syntax highlighter

Navigation: »No topics above this level«

Using the built-in syntax highlighter

 Return to chapter overview

Help & Manuals syntax highlighter helps you to format programming source code examples. The highlighter is aware of the code syntax and reserved words of Pascal, C++, Visual Basic and SQL statements.

To format a piece of text in code editor style

1 Select the topic text you want to format.
2 On the tool bar, click the drop down arrow of the syntax highlighter button.
3 From the popup menu, select the appropriate formatting style.

Once you have choosen a formatting style, you can apply the same style again by clicking the syntax highlighter button directly.

See also

Customizing the syntax highligher

Pascal syntax examples

C++ syntax examples

Visual Basic syntax examples

SQL examples


Virtual Directory Creation

Navigation: »No topics above this level«

Virtual Directory Creation

 Return to chapter overview

To create a virtual directory you should complete the following steps:

1) Open the MMC (Microsoft Management Console) also called the Internet Services Management or commonly refferred to as the IIS administration.

2) You will see a list of snap ins, one of which will be called Internet Information Server. Under this you will see your server name, select this server to view a list of sites running on the server

3) Select the site you wish to add a virtual directory for, right click on this site and select "new", "virtual directory"

4) You will be prompted to enter the alias, this is the name you want to access the content through for example enter "currency" and select next

5) You will be promoted to enter the physical path, this is the path where you unpacked .netCURRENCY, for example "c:\dotnetcurrency\web" you want to point to the web directory as this directory contains the web samples

6) Select "next" and "finish" on the final page.

Your virtual directory is now setup, and you can load the samples through http://www.yoursiteaddress.com/currency/vbnet or http://www.yoursiteaddress.com/currency/csharp